[Avida-SVN] r3147 - development/source/analyze

brysonda at myxo.css.msu.edu brysonda at myxo.css.msu.edu
Wed Feb 11 04:58:59 PST 2009


Author: brysonda
Date: 2009-02-11 07:58:59 -0500 (Wed, 11 Feb 2009)
New Revision: 3147

Modified:
   development/source/analyze/cAnalyzeGenotype.cc
Log:
Fix (temporarily) html.sequence and link.tasksites so that they will be matched and executed as expected.  The period in the genotype data entry name is used to separate arguments from the actual data method desired in 'inst.' and others.  As a result, html.sequence gets truncated to html before matching.  Since there are no current naming clashes, I have simply removed the . component of the name to allow current analyze scripts to work as expected.   In future versions of Avida (likely 3.0) we should rename these data methods.

Modified: development/source/analyze/cAnalyzeGenotype.cc
===================================================================
--- development/source/analyze/cAnalyzeGenotype.cc	2009-02-06 18:38:12 UTC (rev 3146)
+++ development/source/analyze/cAnalyzeGenotype.cc	2009-02-11 12:58:59 UTC (rev 3147)
@@ -306,9 +306,14 @@
   ADD_GDATA(cString (), "executed_flags", "Executed Flags",             GetExecutedFlags, SetNULL, 0, "(N/A)", "");
   ADD_GDATA(cString (), "alignment_executed_flags", "Alignment Executed Flags", GetAlignmentExecutedFlags, SetNULL, 0, "(N/A)", "");
   ADD_GDATA(cString (), "task_list", "List of all tasks performed",     GetTaskList,     SetNULL, 0, "(N/A)", "");
-  ADD_GDATA(cString (), "link.tasksites", "Phenotype Map",              GetMapLink,      SetNULL, 0, 0,       0);
-  ADD_GDATA(cString (), "html.sequence",  "Genome Sequence",            GetHTMLSequence, SetNULL, 0, "(N/A)", "");
   
+  // @TODO - the following were link.tasksites and html.sequence, respectively.  The period character is now separated as
+  //         an argument passed into the function, thus they are matched as the component before the period.  For now
+  //         I have simply removed the argument part, since there are not any existing name clashes.  However,  in future
+  //         versions we should rename these.
+  ADD_GDATA(cString (), "link", "Phenotype Map",              GetMapLink,      SetNULL, 0, 0,       0);
+  ADD_GDATA(cString (), "html",  "Genome Sequence",            GetHTMLSequence, SetNULL, 0, "(N/A)", "");
+  
   dcm->Add("inst", new tDataEntryOfType<cAnalyzeGenotype, int (int)>
               ("inst", &cAnalyzeGenotype::DescInstExe, &cAnalyzeGenotype::GetInstExecutedCount));
   




More information about the Avida-cvs mailing list