[twill] Intel Macs and Twill

John J Lee jjl at pobox.com
Tue Oct 17 15:38:06 PDT 2006


On Tue, 17 Oct 2006, Titus Brown wrote:
> On Tue, Oct 17, 2006 at 02:10:12PM +0100, John J Lee wrote:
[...]
> -> A guess: Perhaps Peri mis-read the message from easy_install explaining
> -> that *easy_install* (not Python) needed to be upgraded.  (S)he would have
> -> succeeded under 2.5 because s(he) would have got the latest easy_install
> -> (and not because it was the latest Python).
>
> Hi, John,
>
> that's a good guess!  But...  does easy_install come with *any* version
> of Python yet?  I had to install it on my own OS X machine.

No, easy_install does not come with any version of Python.

Your point being...?

Installing Python 2.5 and then installing easy_install results in a system 
that has the latest easy_install, and so attempting to install twill will 
not print a message requesting that easy_install should be upgraded.  A 
Python 2.3 system that was installed prior to the attempt to install twill 
may have had an older version of easy_install installed, in which case 
that message may be printed.


John




More information about the twill mailing list