[TIP] Fwd: Bizarre results running Hudson job + CI

Olemis Lang olemis at gmail.com
Mon Mar 22 08:12:56 PDT 2010

After a few days of frustration  :( , I'm forwarding the message to
this list (TiP ;o) because probably somebody has a clue and can help
me to find the underlying issue.

Sorry for cross-posting

---------- Forwarded message ----------
From: Olemis Lang <olemis at gmail.com>
Date: Fri, Mar 19, 2010 at 10:44 AM
Subject: Bizarre results running Hudson job + CI
To: CI4Py <testrun at codespeak.net>

Hello !

Before asking somewhere else I wanted to tell you about an issue I
consider a bit strange . I've setup a buiild job @ testrun.org [1]_ to
test Trac XmlRpcPlugin . It doesn't use a repository 'cause source
code is checked out from a MQ repository hosted by Bb . That also
means that I had to hack a little until I found a way to work around

BTW, it would be very useful (for me ;o) in order to simplify build
steps, if MQ extension could be enabled globally in build slaves . Is
there any chance for this to happen, please ?

Well, it finally worked , but the fact is that it is reporting
inconsistent results AFAICS . For instance build 22 [2]_ displays 4
failures + 19 errors . I ran the tests locally on a my PC and got

test_general_provider_error (tracrpc.tests.api.ProtocolProviderTestCase) ... ok
test_invalid_content_type (tracrpc.tests.api.ProtocolProviderTestCase) ... ok
test_valid_provider (tracrpc.tests.api.ProtocolProviderTestCase) ... ok
test_content_encoding (tracrpc.tests.xml_rpc.RpcXmlTestCase) ... ok
test_method_not_found (tracrpc.tests.xml_rpc.RpcXmlTestCase) ... ok
test_resource_not_found (tracrpc.tests.xml_rpc.RpcXmlTestCase) ... ok
test_to_and_from_datetime (tracrpc.tests.xml_rpc.RpcXmlTestCase) ... ok
test_wrong_argspec (tracrpc.tests.xml_rpc.RpcXmlTestCase) ... ok
test_xmlrpc_permission (tracrpc.tests.xml_rpc.RpcXmlTestCase) ... ok
test_binary (tracrpc.tests.json_rpc.JsonTestCase) ... ok
test_call (tracrpc.tests.json_rpc.JsonTestCase) ... ok
test_call_permission (tracrpc.tests.json_rpc.JsonTestCase) ... FAIL
test_datetime (tracrpc.tests.json_rpc.JsonTestCase) ... ok
test_method_not_found (tracrpc.tests.json_rpc.JsonTestCase) ... FAIL
test_multicall (tracrpc.tests.json_rpc.JsonTestCase) ... ERROR
test_resource_not_found (tracrpc.tests.json_rpc.JsonTestCase) ... FAIL
test_wrong_argspec (tracrpc.tests.json_rpc.JsonTestCase) ... FAIL
test_xmlrpc_permission (tracrpc.tests.json_rpc.JsonTestCase) ... FAIL
test_FineGrainedSecurity (tracrpc.tests.ticket.RpcTicketTestCase) ... ok
test_getActions (tracrpc.tests.ticket.RpcTicketTestCase) ... ok
(tracrpc.tests.ticket.RpcTicketTestCase) ... ok
test_getRecentChanges (tracrpc.tests.ticket.RpcTicketTestCase) ... ok
test_attachments (tracrpc.tests.wiki.RpcWikiTestCase) ... ok
test_getRecentChanges (tracrpc.tests.wiki.RpcWikiTestCase) ... ok


Ran 24 tests in 45.674s

FAILED (failures=5, errors=1)

My concern is because (AFAIK) the job relies on Py 2.6, nonetheless I
get messages like this [3]_

'Internal Server Error\n\nTracError: ImportError: No module named


Could anybody please tell me ( what's happening | how to fix this ) ?
I believed that multiprocessing was available in Py2.6 [4]_ and
previous builds didn't say anything about this and the plugin doesn't
use it (explicitly) at all ...


Any help will be much appreciated . Thnx in advance !

.. [1] Hudson » tracrpc-mq

.. [2] Hudson » tracrpc-mq » #22

.. [3] Hudson » tracrpc-mq » #22 » Test Results » tracrpc.tests.api »
ProtocolProviderTestCase » test_general_provider_error

.. [4] What’s New in Python 2.6



Blog ES: http://simelo-es.blogspot.com/
Blog EN: http://simelo-en.blogspot.com/

Featured article:
TracRpc: API v2: Test cases for XML-RPC ... PASS -

More information about the testing-in-python mailing list